@david-wilsby Could you verify that you have given Flic permission to access the Local network? This is done by going to iOS Settings -> Privacy -> Local network. Make sure Flic is turned on. If it's already turned on, please try to swipe kill the Flic app, toggle this setting to off and then back on and restart the Flic app. Please let me know if this helped! We have seen some bugs around the new Local network permission ad it would be very helpful to get your feedback on if this worked or not! Kind regards, Oskar