can't control WeMo lights directly.

  • I wish I could control a group of WeMo lights directly like I can with the WeMo sockets. Currently I have to use IFTTT for the lights which is too slow, but we have a Flic behaviour for the sockets.

    Please add the lights to the Flic app!

  • I also have a problem controlling wemo lights from flic app (when using the hub). I am using the same LAN. It works fine with my Wemo Switch but the flic app can't find my lights, even though they work fine with the wemo app.

  • @conal_loughrey said in can't control WeMo lights directly.:

    I am also unable to setup my flics to control my wemo bulbs, the app does not find the wemo devices when I search for them. The bulbs are on the same LAN and other third party apps (for example, wemoleds) can find them.

    No - no luck, its very annoying, its the reason I bought the flics - works great with Hue bulbs but not with wemo bulbs.

  • I am also unable to setup my flics to control my wemo bulbs, the app does not find the wemo devices when I search for them. The bulbs are on the same LAN and other third party apps (for example, wemoleds) can find them.

  • Did you ever have any success with this? I'm having the same issue with my new FlicSingle.

  • @anton hi, yes happy to run a version with the logging. Let me know as very keen to resolve this.

  • FlicTeam

    @woodhams Yes the lights are working fine for us and they should work in the release that is currently on the App store. We have also verified this from many of our users. It worries me a bit that you say that the WeMo Light Link does not appear when you search in the Flic app. Perhaps there are different versions of the Link that works different ways that I don't know of. If that is the case then I think the only solution would be if we send you a Beta version with added logging so that we can see the network traffic. I'll think about that..

    One more comment is that we have just now finished the integration for the WeMo US lightswitches (the ones that are wall mounted inside the sockets). So that will be added to the next release.

  • @anton have you guys got it showing the bulbs in testing?

  • Add me to the list, search for devices won't find my Wemo bridge. Rebooted app, phone, router, Wemo bridge etc and tried repeated searches. On 2.1.7 iOS

  • @anton

    Fully tested with multiple restarts of the hardware - the WeMo bulbs are not showing in providers, the sockets appear fine, can control all WeMo devices fine in the WeMo app.

    Any ideas?

  • @anton hi Anton, I will be back on Saturday- will restart everything and see what happens and report back.

  • FlicTeam

    @woodhams The lights should appear in 2.1.6! If they do not appear for you then something is different with your setup than for other people, in which case I would like to move forward with further troubleshooting together with you. However, before we do that I just want to mention that we have noticed that the light bridges sometimes do not want answer to a network scan. Although whenever this is the case then it has always worked to simply scan a few more times, have you tried to scan multiple times in a row?

    I will do my best to make sure that we solve this issue for you.

  • @anton Hi, which version will be released? I have 2.1.6 currently.


  • @anton

    Hi Yes I have three WeMo bulbs connected as a group through a WeMo Link.

    I'm more concerned about getting the bulbs working that the WeMo switch.

    Looking forward to getting the bulbs working next week - I will report back.

  • FlicTeam

    @woodhams Okey good to know! Well I honestly have to say that the current iOS app has a lot of known issues with the WeMo provider as well. For the latest iOS app we did completely re-do the WeMo provider. The main reason for why this was done was due to the fact that we were seeing major stability issues (crashes) originating from the WeMo SDK provided by Belkin. They also recently officially dropped support for their official SDK which lead us to proceed with our own implementation.

    While we did spend a lot of time implementing and testing this we still managed to release a version that ended up not working properly. In particular, we noticed that the WeMo devices will occasionally, for some reason, change ports for their TCP connections which the current release does not handle properly.

    We will release a new app next week which will solve the majority of these mentioned issues. Regarding your lights, I just want to make sure that I understand your setup. You are using a WeMo Link and connecting WeMo lights through that? As I said, I know that the current WeMo provider has issues with the lightbulbs, but I still think that they at least should be discovered during a search..

    Regarding your Light Switches not showing up I have to admit that that is caused purely due to an oversight on our side. The light switches are not available for the european market (which is where we are located) so we sort of "forgot" to implement support for them since we don't have them in our inventory.. We are of course fixing this as well, but it is unclear whether that fix will make it into next week's release.

    Once again, we are very sorry about this! We will do our best to avoid similar problems in the future.

  • HI Anton,

    No, i'm on iOS (current Flic app version), basically I go to the providers section activate WeMo and only my switches (sockets) appear, the bulbs / bulb groups and the light switches do not.

    When I want to create an action again only the we switches (sockets) appear.

  • FlicTeam

    @woodhams Are you on Android? The Android app should be compatible with WeMo light if they are connected via the WeMo Link (bridge). In particular, the app released yesterday has made improvements to light compatibility. Do you mean that the lights do not appear in the app at all, or simply that you can not control them in a group?

    On iOS we have unfortunately had a lot of issues with the WeMo integration. We are about to release a new app version there as well with major rework.

Log in to reply