Android 7, All Flics Locked

  • Nexus 6p, updated to Android 7.0 almost a month ago or so. Flic app has been updated a couple times. At first after the OS update, no Flics would work. Then the Flic app received an update. Then ONE of my flics worked for maybe a day or so.

    Now none will work. Every time I try to reconnect, the "your flic is locked" message comes up. No amount of pressing and holding clears this.

    Last major OS update the same thing happened, but about a month in the Flic team fixed it.

  • @Emil, probably they're not BLE, whatever that means, but they work.

  • FlicTeam

    @flocsy What Bluetooth buttons did you buy for less than $2 each? Are they BLE?

  • Seems everything is working fine now after I uninstalled the app, then reinstalled it. After it downloaded the key for each Flic and then I reset them, they're working OK. Appears something in the app itself got buggered up.

  • @defilade1310 I have similar "saga" experience :( The current status is that it's "solved" by the fact that Flic doesn't work on my wife's phone, so I don't "need" the Flics to work on multiple devices and they work fine with mine, however I feel pretty bad with my purchase. I spent $110 on 4 Flics, and they have more problems than times when they work. Previously I bought 3 cheep Bluetooth buttons for less then $2 each, and I have to tell they work without problem (the reason I bought the Flics is that they have the android sdk)

  • Odd, when I got home in the morning, the Flic app 'saw' a couple of my Flics, and they worked. One of them it did not. I had to remove it and add it again, and after a little hoo-hah, it started working.

    Then I got to work, and the Flic I previously stated I had working after removing it and re-adding it... now does not work again. Trying to do the "add Flic" without removing the Flic first, indicates the Flic is locked. Removing the Flic then trying to connect, it finds the Flic and says it's locked again. Holding for 7+ sec and trying again, I get "couldn't connect to Flic". Then trying again says it's locked.

    Next I completely uninstalled the Flic app and tried adding the Flic again. It did give me the "locked" message, but after holding for a few seconds, it connected and appear to be working.

    The rest of my previously configured Flics show up in the list, but have the red circle "download" tag. I'll have to try those when I get home.

  • OK, I got one of my flics working.

    I'm at the office, where I only have one Flic. Decided to try something. I removed it from the app, deleted the config and then tried to add it. It popped up the "found new flic" dialog, but it failed to connect. Retrying, it said the Flic was locked again. I tried the "hold for more than 7 seconds" and repeated. It found the Flic and connected. Now it works.

    So I should be able to repeat this for the few Flics I have at home. Kinda sucks. I didn't want to have to redo everything. At least they're simple. I just have all the actions set to "send android intent" and then have Tasker executing things from there.

    Will update if it works or not.

  • @flocsy Doesn't work. Tried multiple times on multiple flics. Still keeps saying they're locked.

  • Strange, but try to unlock them as it suggests: hold the flic for more than 7 seconds, then retry (Or "download" is how it's called now)

Log in to reply