Double red blink on Flic

  • Today when I press my Flic button it flashes a red at me twice and does nothing.
    The app shows the button as disconnected.
    I've tried taking the battery out for a period of time, and tried replacing the CR2016 with a new battery ... but I get the same result.

    This Flic button is 18 days old.

    How can I resolve this?

  • @pdo-smith

    I have tried this but flic app button is still reporting it is out or range

  • @pdo-smith The solution for me was to turn Bluetooth off and then on again on my iOS device and then it worked again.

  • Changed the battery on my Flic this week, it answered with blinking red twice when pushed and by not being found by the app. I have tried two different phones, rebooting the bluetooth and everything else above.
    So, what to do?

  • @proto732 A fourth measure that really works for me is to restart the Bluetooth subsystem.
    I use this app:
    and it invariably fixes the problem for me.

  • The double red blink means that the button thinks your phone is out of range. This means that your phone is not replying to the advertising packets broadcast at 1800 msec intervals by the button.

    1. A likely cause is that a task killer app on Android shut down background tasks, disabling the Flic service. Once disabled it cannot reply to the button's advertising packets and so the button thinks it is all alone in the world! This is often done to conserve memory and save on battery life. The fix is to place flic in the app's whitelist so that it is not shut down.

    2. Another, related, possible cause is that your version of Android is not allowing flic to run as a background task. The fix is to change the settings so that flic is allowed to run as a background task.

    3. A third, possible cause is that you are using an ad blocker like Adguard. This prevents the flic service from reporting back to HQ(naughty boys!). The fix is to put in the ad blocker's white list.

    I found it necessary to use all three fixes.

  • After a full day of the mysterious double red blink, this button suddenly started working normally again. did respond with some troubleshooting steps, but I never even got to them.

    I'm not a fan of unexplained mysteries.

Log in to reply