Flic Hub internet request broken



  • Hey,

    I am trying to set up a simple Internet Request to control Home Assistant through the hub but it just wont work.

    If i copy and paste the information to a virtual flic everything works fine.

    Is there something im missunderstanding?


  • FlicTeam

    Hi. Have you tried to set up http://postb.in and use such an URL instead? Then you can inspect what the hub sends. We have plans to improve the error handling of HTTP Request but aren't quite there yet.



  • No HTTP has been broken since the early beta. I reported the issue very early on but they just never worked with me to fix it.

    For example this curl command works fine on the command line.

    curl -X POST -H "x-ha-access: secure_password" \
           -H "Content-Type: application/json" \
           -d '{"entity_id": "switch.room_light"}' \
           http://192.168.1.90:8123/api/services/switch/toggle
    

    However using flic POST with
    content type:

    application/json
    

    header variable:

    x-ha-access: secure_password
    

    body:

    {"entity_id": "switch.room_light"}
    

    URL:

    http://192.168.1.90:8123/api/services/switch/toggle
    

    Does not work! If it works in curl it should work in flic.

    The lack of logs or any other feedback has been a flic hub complaint of mine since the beta program. The issue may be POST not getting set, headers not getting set, Perhaps the backend code is stripping the quotes from the json, who knows. We get no error, it just ignores our request. So how can we debug!!!!

    I can tell you that a simple GET works. I wrote a simple middle man server in Node for my SmartThings hub because the SmartThings API is complicated so I thought that was part of the problem. So I have local server which accepts simple get requests and issues the more complex POST requests to SmartThings. It works perfect with Flic hub, when the buttons are responding.

    Now that I am moving over to HA and they have such a simple API I expected it to work. But nope...

    The indiegogo campaign promised developer level access to the hub but I can't even get user level access to the logs or anything else on the hub.

    My hubs work about 80% of the time. When they don't work I have to guess why.

    I created bug reports on this during the beta program and was never contacted. I posted the issue to the facebook ambassadors campaign. No fix.

    So I figure I might as well try here too. Don't expect much.

    OK now I have to go off and write a middle man simple GET request server for HA so I can get my devices working with Flic Again.....How annoying!


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.