Lifx Lan has become unusable

  • Basically both with hub v1 and hub v2, lifx Lan toggle will not turn on or off all lights in the same group. It becomes an endless nightmare some lights are on and some lights are off.

  • If you want more advanced control over your LIFX devices, I wrote a blog post with a few examples of how to leverage Photons Interactor to do some really nifty stuff, including starting/stopping Tile and Beam animations.

  • @Emil yes that seemed to cure it.
    I guess i'll just have to give my lights static ips!

  • @Emil It's working!! Praise be. Praise be. Thanks again!! ( :

  • @Emil Yay! Thanks Emil.

  • FlicTeam

    Ok so we found the issue. It was in the newest Flic hub software. The issue is more likely to happen as more Lifx Lan lights you have selected to toggle. It will be fixed in an upcoming firmware (2.0.14).

  • I have the same issue: I have four LIFX bulbs and about half the time, not all the lights get triggered. I am using "toggle" with a Flic2 and Hub2. When I use the cloud integration, they always switch on/off but there is a delay.

    I'd be happy to try anything to see if it helps. Is there a way we can send logs?

  • FlicTeam

    @gazhay could you try delete the light from the LIFX LAN provider list, and add it back? Maybe it has changed IP address. Please tell how that works out.

    Does the light work from the phone's flic app? (when not connected to hub)

  • @anton

    1. & 2. I only use toggle for the LIFX over LAN settings. I have double clic and long clic programmed for certain scenes that go through LIFX (not over LAN), which work just fine. I can try changing the color settings and also try "on" or "off" but that's not how I'm interested in using the flic... so not sure why that would of value other than to trouble shoot? I can give it a try.

    2. I'll give you an example: When I left my home location this morning all six of the lights in the room were on. I clicked once and all but one light went off. I clicked again and all the lights turned back on. I clicked a third time and again all lights except the same one as before turned off. I lcicked a fourth time and they all turned back on. I clicked a fifth time and all the lights finally turned off, I rolled my eyes and left.

    3. Continued. In my office, where I am now, I have 11 bulbs + a tile (5 panels). I just clicked and it took 7 times starting with all lights on to get them to all turn off at the same time. Sometimes it only takes 3-4 clicks, sometimes 10+. It almost never works in one click anymore, which started about a month ago right, around the same time gekim.84 reported it.

  • FlicTeam

    @garethw00 I have some follow-up questions:

    1. Is the behavior the same regardless of the color setting, as in, does it still happen if you choose the option to keep the current color and not alter the color setting?

    2. It is slightly unclear whether you use toggle or on/off. Can you verify that the issue is still the same if you have only "on" or "off" and not "toggle"?

    3. What exactly do you mean when you say "First one or two turn off, then they all come back on"?

    Sorry for the inconvenience, but the more information the better.

  • @anton Thanks for the response! I didn't set up my new LR hub yet but just cloned one of my existing flics to a new flic 2 and it does the same thing.

    It typically turns on 5 of my lights at one location (four minis and one set of 5 tile panels) in two to three button presses. Same for turning off. First one or two turn lights turn off, then they all come back on, then they all finally go off after another press or two. It's been just the last month for me. One day it just stopped working consistently. So now I'm yelling at Alexa more but she's had her own issues. Bad AI. Bad girl. No treat for Alexa. Or Flic. : ) hehe.

  • Lifx lan appears to have stopped working altogether for me.

    Was working fine for a month, now nothing. Cloud works fine. I can use python to toggle lights over lan, so its flic/flichub issue.

  • FlicTeam

    @garethw00 I will take another look at the implementation of the LIFX LAN toggle feature next week. Although I can't seem to understand why it would occur. The toggle feature sends the same command to each lightbulb once the toggle state has been decided. So it should not be that they end up with different states.

    The only thing I can think of is if some of the lights for whatever reason don't process these commands properly.

  • gekim.85 did you get any resolution to this? Just got my Flic2s and it's the same deal.

  • @Emil thank you for your reply. That did it. I rebooted all the LIFX bulbs, and now they are showing up as expected. Just got my Flic Hub LR today and it instantly saw all LIFX LAN bulbs.

  • FlicTeam

    @mcmate4 I don't know but maybe the LAN feature in some LIFX light has hung (I've seen this before, while the Cloud listener still worked). You could try reboot the light.

  • I’m thinking that there’s something broken in the local connection. I have LIFX lights that show up and execute fine in The lifx app, as well as SmartThings and Harmony Hub, but only display as the IP address for the device and are not controllable via the LAN execution.
    Works and shows symbolic names from cloud, but has a delay.

    Any assistance would be appreciated.

  • I have the same issue with 3 different hubs at 3 different locations. Sometimes takes 4-5 button pushes to get them all to turn on or off... just started happening in the last few weeks. Any ideas?

Log in to reply