Flic Hub can't establish working connection over Ethernet

  • Our scenario is the following: Flic button sending HTTP GET Request to PC in local network (

    However it doesn't work. The package should be captured by an app called vvvv, where we count how many packages came in. Sometimes it works, if we spam the button 20 times, it sometimes counts one!

    We tested the following

    • connecting to the same network over WiFi in the same scenario works
    • connecting to a different network (an isolated one, just router and PC) works as well
    • sending the HTTP request from a different machine (another PC in the network) works
    • connecting the hub through a different cable and/or different port on the switch doesn't work
    • tried deactivating Windows Firewall, still doesn't work
    • tried assigning a different IP to Flic Hub and PC
    • since the package are coming through every once a while, it's not a blocked port, IP, service that blocks the whole communication

    And a lot more that came to mind, we tried. We've been troubleshooting for two hours now and we aren't certain it's actually a problem with your product, could be a misconfigured network setting or something. We do have a managed switch in the network.

    I hope you guys have an idea what to do from here, since we are out of ideas!

    Things, we still want to try, but probably won't help:

    • Try sniffing the http request with WireShark on the Windows machine to see if the package arrives at all and our programm just doesn't catch it or if it never reaches its destination
    • Fiddle around in the managed switch and tweak the settings, eventhough everything is configured rather 'open' without many restrictions (we already tried turning off some obvious ones)

    Thanks for your help!

  • I've had a similar problem today. I connected my Flic Hub to the Ethernet port while being connected to wifi. Then I disconnected wifi from the mobile app.

    I clicked on Test Connection and confirmed the Internet access however Ethernet was showing not connected in the app however I couldn't log in to the SDK.

    While the Flic Hub was powered, I removed the ethernet cable and plugged back in and it reassigned the IP. Then it worked.

  • FlicTeam

    @leonardchrist do any other actions work? Like IFTTT, Flow, Zapier, Spotify, Sonos, lights and so on?

  • Hey Emil,

    still no luck on anything. We reset the hub to factory settings but it doesn't work. We of course tried Ethernet without having the WiFi connected, which is the case in which it doesn't work!

    Best wishes,

  • FlicTeam

    @leonardchrist Hmm that might be an explanation. Could you disconnect the WiFi while you are on Ethernet?

  • Hey Emil,

    thanks for the quick reply! Here's what we captured with WireShark:

    When the Hub is connected via WiFi (everything works):

    • Establishing session: TCP SYN from Hub -> PC
    • Establishing session: SYN ACK from PC -> Hub
    • Establishing session: ACK from Hub -> PC
    • Data Sent: HTTP GET from Hub -> PC
    • Data Received: HTTP OK from PC -> Hub
    • Closing Session: FIN ACK from PC -> Hub
    • Closing Session: ACK from from Hub -> PC
    • as well as RST_ACK, ACK, ACK

    Here's what happens when the Hub is connected over Ethernet:

    • TCP SYN from Hub -> PC
    • SYN ACK from PC -> Hub

    And than we never get an ACK from the Hub back, so it never establishes a session and therefore can't send the HTTP request. Then several TCP Retransmissions, as well as a final RST, the PC closes the session.

    We already tried restarting all the devices (Hub, Router, PC, Managed Switch, Router) without any success.

    A wild guess, for now, would be that the Hub sends the first SYN package to the IP and then gets a response from that PC including its MAC-Adress. At that point the Hub sees that MAC Adress in its ARP-cache table and goes "I know that MAC address, it's on interface 'wifi'" and tries to go there instead, which isn't configured.

    We will try some further troubleshooting! Any help would be much appreciated as we already spent a lot of time on it!

    best wishes,

  • FlicTeam

    Hi. We have never seen any problem like this before. Just tested HTTP request to my computer running a "python -m SimpleHTTPServer" and saw all clicks coming through. The hub just runs a normal Linux OS and a HTTP request is not much more than a TCP connection with a message back and forth. You should try set up Wireshark or something to try to find the issue.