Supporting both Flic 1 and Flic 2 in the same app



  • Hi there,
    We have an existing integration for Flic 1 buttons and would like to support Flic 2 as well.

    When following the existing process (i.e. fliclib-ios), the Flic 2 button is detected in the Flic App, but just says 'not compatible'

    If we want to support both Flic 1 and 2, will we need to incorporate both SDKs into our app and prompt the user to pick which model they have?
    Are there any plans for a consolidated API that will support both?

    Thanks



  • Thanks Emil for the quick reply and the clarification.

    That makes sense, just wanted to make sure I wasn't missing anything.


  • FlicTeam

    Hi!

    Yes you need to add the Flic 2 SDK. Please prompt the user which Flic version they have so you can call the right API.

    There are currently no plans for making a unified API.


Log in to reply