Alexa and FLIC integration.



  • Alexa integration is not working for me, my Alexa app is not discovering the flics at all. I have tried disabling/re-enabling the Flic skill, removing and adding the flic button, but the Alexa app does not discover the flics. I removed the mkZense IFTTT skill to try this official Flic integration but guess I'll have to go back to it.



  • @Emil I was getting the "This Device is not supported" message while trying to set up my first routine in Alexa as well. After some troubleshooting here is the workaround I found.

    Assuming that you have already enabled the Flic skill within the Alexa app:

    1. Open "Devices" menu in the Alexa app and find your Flic
    2. Delete/Forget the device
    3. Fully close the Alexa app. (It shouldn't be running in the background either)
    4. Fully close the Flic app. (again, it shouldn't be running in the background)
    5. Open Flic, set up the button to trigger Alexa if you haven't already.
    6. Open Alexa and click the button - it should say, new device discovered.
    7. DO NOT CHANGE THE NAME OF YOUR BUTTON IN ALEXA
    8. Create a routine and start from the bottom, i.e. Actions -> Triggers -> Name.
    9. Now it should work successfully.

    This worked for all three of my buttons so hopefully it works for others as well.


  • FlicTeam

    @agheler You need to make sure you have internet connection on your iPad. Then also make sure you actually save the action by pressing "Done" inside Alexa action configuration, and then press the back button to reach the main view.



  • So happy to hear about this integration! Do you need the hub for this integration? I use an iPad as hub and I added the action to a flic 2 and then added skill in Alexa app but it did not discover any new devices (I have 4 Flics). Am I missing something?



  • @ste-midgley
    I had a had the same error message at first. It seems that trying to assign a name for a new routine in the Alexa app first was confusing something.

    I did the first setup in the flic app, then changed over to Alexa. Enable the skill (if not already) then create a routine. Instead of giving it a name, try going to the 2nd option “when this happens”, choose “smart home” then your flic button. It then gives it a name, and let me pick the actions to perform.


  • FlicTeam

    @ste-midgley We have activated the Alexa skill in all available countries and for every possible
    language. Honestly we do not know what this message means. We have never reproduced this message ourselves when we have been testing, but heard of a few persons who got this issue.

    If you find a solution or workaround, please let us know. Also let us know the region and language you have selected in Alexa.



  • @Emil said in Alexa and FLIC integration.:

    We are slowly rolling this out in different regions. Stay tuned.

    Do you have any details on which regions are/are not working yet. I just bought a flic button kit as it said alexa integration was already done. I added the skill on alexa, found the devices (1 each for click, double click & hold) However these are not able to be used. When trying to add them to a routine it just says "Error - This device is not currently supported"

    Did I just waste my money?



  • @Emil thanks for your fast response. I tried it quickly and measured around 50 tries with varying results. First of all I used just a speech output from my Echo as you recommended. The normal response was about 2-4 seconds which is absolutely acceptable.

    Then I directly talked to my echo speaker to turn my light on and off, this was also very quick with about 2-4 seconds.

    I observed sometimes my flic glowed orange and sometimes it took very long to response with both, the speech and the light.

    It could be that all devices add a small delay and in total it feels rather slow.


  • FlicTeam

    @jonas This is not something we've heard of. It reacts "instantly" in our tests and that has been the response from our customers too.

    Are you sure the Flic integration itself is slow, and it's not your lights or whatever you have hooked up Alexa to do after receiving the trigger? You can set up Alexa to just say something upon pressing the Flic button, that should be the best way to test the latency I guess.

    Also make sure both the Alexa hub and the Flic hub have good wifi, or ethernet connectivity.



  • Its finally here and I ditched my workarounds for doing this before. Now I have the problem that the skill is rather slow and can take up to 20 seconds sometimes. Is this normal or is there a possibility to reduce the latency?



  • It's live!



  • @Emil @leapoldstoch1 This is a total game changer now for my Flic buttons. I don't believe you can toggle lights with one trigger action, but I'm still very happy with the integration nevertheless! 😄👍
    I used to use IFTTT which used to work ok but since I have started paying to use the applets, it hasn't worked properly or when it does, the response is soooooo slow! Methinks I'll cancel that subscription now!
    Thank you so much for this developers, this had endless options! 👏👏👏


  • FlicTeam

    @leapoldstoch1 not what we know. Note that Alexa devices are originally meant for voice, and I doubt the device makers have added the phrase "Alexa, toggle my lights please" as a matching phrase...



  • @Emil congratulations this is amazing ..... is there any way however to toggle routine on routine off ?


  • FlicTeam

    @leapoldstoch1 In that case, just make sure you have the latest flic app installed.



  • @rmainva1

    Here is a step by step approach to configuring a Flic button called “TEST BUTTON” to run Alexa routines. if you’ve used iFTTT before the process is similar.

    1. In Alexa SKILLS & GAMES search for and enable the Flic skill. (you will only have to do this once)
    2. In the flic app add a new Flic button and name it TEST BUTTON
    3. In the TEST BUTTON configuration page, under Click, Double Click, Hold, add the new Amazon Alexa Trigger option. Each of these triggers will show “This action has no configurable actions”.
    4. In the Alexa app select Routines and scroll down until you see TEST BUTTON - Click is pressed etc.
    5. In the Edit Routine page add your required action. I found it easier to omit renaming the routine as the app will name the routine using the default name of the trigger e.g. TEST BUTTON - Click is pressed

    That’s It, I hope it works for you,
    Norman



  • @Emil hi Emil, there is no Amazon Alexa option on the actions list.


  • FlicTeam

    @rmainva1 please follow this guide https://flic.io/alexa/setup



  • @norman-vezey How did you get it to work. My Flic action says there is nothing to configure? Am I missing a step?



  • @Emil Works a treat! This is a game changer for me, I'm now in the process of adding my Alexa Routines and everything seems to be working fine so far. I have been using IFTTT pro until now, the main difference I've noticed so far is the speed of execution, I have however many Routines so the update process will take a while. Thank you so much for implementing this feature.


Log in to reply