FLICHUB making 500+ DHCP requests a day

  • I recently purchased a FLICHUB LR. It is hooked to my network via ethernet since the FLICHUB does not support WPA3. It has a static IP address assigned with a DHCP lease time of 1440 minutes (24 hrs).

    For that past couple of weeks I have found the flichub is sending a DHCPREQUEST roughly every 62-67 seconds.
    Shortly after 12am the interval is every 62 seconds. At some point that interval increases usually by one second until it reaches 67 seconds 2-3 hours before 11:59pm. I tried power cycling the HUB multiple times with no change. I have tried resetting it to default four times then reconfigure it, but it still does not change.

    How do I make the flichub stop this behavior?

  • I observe the same thing with repeated DHCP requests from both flic hubs I am running. I run a regular debian based isc-dhcp daemon on the server, and no issues except for flic hubs. Something is strange with the flic hub implementation.

    @Emil: can you elaborate on what flic hub expects? Is it possible that flic hubs expects an answer from the Wifi router? In my case, and possibly in yea's case, the DHCPD is running on a different machine, so the MAC address could be different.

    Here an example:
    Jan 6 16:31:22 xxx dhcpd[6493]: DHCPREQUEST for from 76:ee:2a:9c:c8:38 via enp0s31f6
    Jan 6 16:31:22 xxx dhcpd[6493]: DHCPACK on to 76:ee:2a:9c:c8:38 via enp0s31f6
    Jan 6 16:32:26 xxx dhcpd[6493]: DHCPREQUEST for from 76:ee:2a:9c:c8:38 via enp0s31f6
    Jan 6 16:32:26 xxx dhcpd[6493]: DHCPACK on to 76:ee:2a:9c:c8:38 via enp0s31f6

    The DHCPACK comes right away. Is it possible, that the server is to fast for flic hub to get the message?

    Thanks for any pointer. It is really annoying to see all this internal traffic.

  • @Emil Well I finally got back to playing around with the FLICHUB again. I have configured the hub to use wifi instead; however, before that I configured the access point nearest the FLICHUB with a new virtual SSID that has both Network and Access Point isolation enabled. Then all DNS traffic for that network is force redirected to OpenDNS preventing access to all known malware and botnet command & control servers. I think that fairly well sandboxes the FLICHUB to a point where I really do not care what the hub does other than send out traffic to other services such as IFTTT.

  • FlicTeam

    @yea in that case your router's malware detection is obviously wrong since we don't run malware on the hub.

    We run the dhcpcd software on the hub as dhcp client if you wonder, which is pretty standard.

    For SmartLife, you can use IFTTT to control it from Flic.

    Let me know if you have some more interesting info for this issue, so it can be solved.

  • @Emil, Well no, that behavior has now proven to be nothing more than an annoyance, since a new problem has developed when my Ubiquiti Security Gateway received a firmware update today. Now the SG keeps flagging the flichub as infected with malware and denies all access to the flichub.

    I disconnected the flichub from my network. Besides I have not found a way to integrate my Tuya/SmartLife compatible wifi smart plugs with the FLIC2 buttons yet.

    I'll revisit this problem after the holiday.

  • FlicTeam

    Hi. This usually means the DHCPACK is not received for some reason, causing it to ask again after a minute. Have you tried another router if it's the same there?
    Does this behaviour lead to some specific problems for you?

Log in to reply