Home Assistant (HASSIO) - FLIC 2



  • Hi
    I have installed hassio addon (https://www.home-assistant.io/integrations/flic/), followed all the steps and installed the Service as well with Configuration.yaml binary sensor.

    The server is running as follows:
    Available HCI devices found:
    hci0
    Trying hci0
    hci0 is busy, shutting down and retrying...
    Successfully bound HCI socket
    Flic server is now up and running!
    Initialization of Bluetooth controller done!
    Accepted new client

    But i cannot add any Flic though am pressing the flic for 7 seconds.
    tried pairing it with android app and it is working great.

    So i assume its home assistant issue.

    Please advise ? Anyone successfully paired Flic2 ?


  • FlicTeam

    @flic-i yes you can run simpleclient on another machine, but make sure flicd is started with "-s 0.0.0.0" or otherwise it can only be reached from localhost.



  • I get the same output and results as traboulsizs and am also running Hassio, in my case on a Raspberry pi 3 B.

    I can't find any output in any log that discovery is actually starting, even though I set discovery: true. I also tried a never used Flic 1 and it's also not getting picked up. Maybe this is a problem in Home Assistant?

    Can I run simpleclient on another computer and connect to flicd on the Hassio machine?


  • FlicTeam

    @traboulsizs simpleclient is not part of home assistant, but part of fliclib-linux-hci. You can find the tool here: https://github.com/50ButtonsEach/fliclib-linux-hci/tree/master/simpleclient.



  • @Emil
    I am trying now with a new flic which is not connected to Android.
    Changed my discovery to false:

    binary_sensor:
      - platform: flic
        host: 192.168.1.xx
        discovery: false
    

    No Luck !

    Is there a way to install the simpleclient in Hassio ? As per my knowledge that is not possible.



  • This post is deleted!

  • FlicTeam

    Hi! The button can only be connected to one device at a time, so please first disconnect your Android device.

    Then I recommend you set the "Discovery" setting in home-assistant to false since I think it's a security issue otherwise. Instead use the simpleclient tool or similar to pair the button to flicd. If you have Flic 2 then make sure you use the latest flicd version.


Log in to reply