Home Assistant (HASSIO) - FLIC 2

  • Hi
    I have installed hassio addon (https://www.home-assistant.io/integrations/flic/), followed all the steps and installed the Service as well with Configuration.yaml binary sensor.

    The server is running as follows:
    Available HCI devices found:
    Trying hci0
    hci0 is busy, shutting down and retrying...
    Successfully bound HCI socket
    Flic server is now up and running!
    Initialization of Bluetooth controller done!
    Accepted new client

    But i cannot add any Flic though am pressing the flic for 7 seconds.
    tried pairing it with android app and it is working great.

    So i assume its home assistant issue.

    Please advise ? Anyone successfully paired Flic2 ?

  • I know your post is old, but I've been struggling too with connecting Flic 2 and Home Assistant. Using Flicd addon didn't give a stable integration, but this is a workaround I've found was quite stable. Works only with a Flic Hub and Apple Homekit running!

    1. In Home Assistant, set up an input boolean for single, double and hold for each Flic button. That's three input booleans for each button.
    2. Then expose Home Assistant to Homekit via the Homekit integration. You should now be able to control Home Assistant entities in Homekit, including your new input booleans.
    3. In the Flic app, set up your Flic button to run through Homekit
    4. In Homekit app, set up the button to turn on the input booleans corresponding to single, double and hold press.
    5. You can now create automations in Home Assistant, that fires when the states for your input booleans turn on. Also make an automation that turns off the input booleans again.

  • FlicTeam

    @flic-i yes you can run simpleclient on another machine, but make sure flicd is started with "-s" or otherwise it can only be reached from localhost.

  • I get the same output and results as traboulsizs and am also running Hassio, in my case on a Raspberry pi 3 B.

    I can't find any output in any log that discovery is actually starting, even though I set discovery: true. I also tried a never used Flic 1 and it's also not getting picked up. Maybe this is a problem in Home Assistant?

    Can I run simpleclient on another computer and connect to flicd on the Hassio machine?

  • FlicTeam

    @traboulsizs simpleclient is not part of home assistant, but part of fliclib-linux-hci. You can find the tool here: https://github.com/50ButtonsEach/fliclib-linux-hci/tree/master/simpleclient.

  • @Emil
    I am trying now with a new flic which is not connected to Android.
    Changed my discovery to false:

      - platform: flic
        host: 192.168.1.xx
        discovery: false

    No Luck !

    Is there a way to install the simpleclient in Hassio ? As per my knowledge that is not possible.

  • This post is deleted!

  • FlicTeam

    Hi! The button can only be connected to one device at a time, so please first disconnect your Android device.

    Then I recommend you set the "Discovery" setting in home-assistant to false since I think it's a security issue otherwise. Instead use the simpleclient tool or similar to pair the button to flicd. If you have Flic 2 then make sure you use the latest flicd version.

Log in to reply