Can't connect to hub - how do I reset it? - Resolved



  • My hubs arrived yesterday. I have set one up, updated it to 1.1.0 through the mobile app, configured wireless and attached one flic. The indicator light was amber.

    After switching off and on, I could not access it and the indicator light is red. I have connected wireless and wired, same result.

    On the mobile app, I have removed the hub and tried to re-connect, the app detects the hub, asks for the password from the base of the device and after a couple of minutes from pressing connect,the message "Connection timed out" appears.

    I have tried pressing the reset button but this makes no difference. I am unsure of the exact reset process as it doesn't seem to be documented anywhere so just tried pressing it for a few seconds whilst switched on.

    Can you clarify what the correct process is to re-set a flic hub?



  • @oskar

    The link shows the following which is different to the comments you made, is the current link data correct? I want to check for firmware update.

    "When should I do a "user data restore" or a "factory reset" on my Hub?
    If you ever forget your password to the Flic Hub then the only way you can access it again is to push the restore button on the Hub for 1-2 seconds. We hope you don't forget the password as doing a user data restore will wipe all your paired Flic’s and their existing configurations. You will need to therefore reconfigure all these after a restore.

    In case something goes terribly wrong and the Hub is not working properly, you can factory reset the Hub back to default settings. This is achieved by pressing the restore button for 20-25 seconds.
    The difference between this and the "user data restore" is that factory reset will also reset the firmware to version 1.0, so if you were using features added in new updates, you will need to update your Hub in order to use these. The Hub will automatically update itself if it has a Internet connection, but it might take up to 24 hours. If you don’t want to wait, you can connect to the Hub using the Flic app and manually trigger the update, or push the pin hole button between 2-5 seconds to initiate a firmware update. The LED will begin to blink slowly to indicate that it is currently downloading and installing a new firmware version. "



  • This post is deleted!


  • Thanks @oskar

    I am using a WileyFox Swift 2 Plus (Android 7.1.2) device.

    I have tried resetting bluetooth on the phone to no avail therefore applied the user data reset but a phone reboot was what ultimately resolved the issue.

    I will post back here if I have further related issues.


  • FlicTeam

    Hi!

    Sorry to hear you are having problems. May I ask if you are using Android or iOS and which model/brand?

    The amber color of the LED simply means that it is connected to a phone. The default color is Red and is no indication of a problem.

    When you try to add the hub in the app, can you see if the led is amber/yellow at any time in this process?

    First of all, you should try turning off and on bluetooth on your phone to make sure that it's not on your phones end. It's quite rare that the hub ends up in a broken state after pulling the power, but it is possible if you would pull the power exactly when it was writing something to disk.

    The reset button is used for a few different things, and since factory reset should be the very last resort, we made sure you wouldn't trigger it by accident.

    The reset button functions are as follows:

    Check for firmware updates:
    1-2 seconds

    User data reset: (Try this first, this will remove all settings and user data but not downgrade your firmware)
    10-15 seconds

    Factory reset: (This will remove all data and restore the firmware to version 1.0.0)
    20-25 seconds

    This information can be found on https://start.flic.io

    Please keep me posted on your progress!


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.