'Error Not Authenticated' on Update Firmware from 3.0.3

  • Just got my Pro kit and could not get Alexa integration to work. The Skill seems to install and log in OK, but "Alexa, Discover my devices" finds nothing (and yes, I have connected my six buttons and assigned an Alexa trigger to one of them). I also tried both pressing and not pressing the Flic button during the discovery time. I'm using the Android app on a Samsung Note 9.

    As part of my (extensive) attempts to fix this myself (and yes, I have read the instructions!) I tried to do a firmware update to the hub. The instant I press the 'INSTALL FIRMWARE' button it briefly flashes a 'Downloading' progress page and then replaces this with "Update Firmware: Error Not authenticated". Attempts to assign many of the actions to buttons now fail with "Hub update needed". I have tried this operation several times both with Ethernet and WiFi connection to the hub.

    I have to say this device has not made a good first impression!

  • @Emil Thanks: whatever you have done seems to have worked. My hub updated successfully to 3.0.9 and Alexa integration now seems to be working.

  • FlicTeam

    @john-hind Could you please try again now?

  • @Emil
    Serial Number is HBACE16-24201

  • FlicTeam

    @john-hind sorry to hear that. Maybe if you could give us the serial number of the hub, we could try to look up what has happened.

Log in to reply